Fix mailbox delegation issues in Outlook

Problem scenario:

  • The user sends an email from a shared mailbox and received an error messages stating “This message could not be sent. You do not have the permission to send the message on behalf of the specified user.”, yet the user does have the correct permissions.

  • Name or email changes not reflected in the user’s inbox.

 

Cause:

The user’s Cached Address book has not updated.

Solution:

Update The Offline Global Address List.

  1. Open Outlook, Click on 'Send/Receive' located at the top, → Click on ‘Send/Receive Groups’ → Click ‘Download Address Book…’.

 

2. Make sure ‘Download changes since last Send/Receive’ box is checked , and ‘Offline Global Address List’ is chosen from the drop list (both should be the default option). Click OK and wait a couple of minutes, then Restart Outlook.